Changes between Version 1 and Version 2 of Betaseattleclearinghouse

Changes between Version 1 and Version 2 of Betaseattleclearinghouse

Please note that these Trac pages are no longer being updated. Wiki contents/documentation have moved to GitHub.

Changes between Version 1 and Version 2 of Betaseattleclearinghouse

Please note that these Trac pages are no longer being updated. Wiki contents/documentation have moved to GitHub.

Changes between Version 1 and Version 2 of Betaseattleclearinghouse

Show
Ignore:
Timestamp:
08/20/12 20:49:08 (7 years ago)
Author:
monzum
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Betaseattleclearinghouse

    v1 v2  
    1010[[br]] 
    1111'''[http://betaseattleclearinghouse.poly.edu betaseattleclearinghouse.poly.edu]'''  
     12[[br]] 
     13__Operating System__: Red Hat 4.4.6-4 
    1214---- 
    1315[[TOC(inline)]] 
     
    2426[[br]] 
    2527Instructions on how to deploy a new clearinghouse can be found at this page: [wiki: SeattleGeniInstallation] 
     28 
     29==== Known Issues ==== 
     30While loading the clearinghouse on to the new machine, there were some issues that we needed to get around due to the operating system/default configurations already on the machine. 
     31 
     32__Configuring Apache:__ 
     33The version of Apache available on RedHat is slightly different then the one available on Ubuntu/Mint or other distros. The installation path is in /etc/httpd/. The configuration file is located at /etc/httpd/conf/httpd.conf. Below are some of the issues that I ran into while configuring the Apache conf file. 
     34[[br]] 
     35 * Load ssl module. The ssl module was initially not installed on the machine. In order to install it, run the command: 
     36{{{ 
     37# yum install mod_ssl 
     38}}} 
     39 Once installed, open up the httpd.conf file and add this line after all the !LoadModule lines: 
     40{{{ 
     41LoadModule ssl_module /modules/mod_ssl.so 
     42}}} 
     43 * Load python module. The python module was not available from the package manager so I had to manually install this. First retrieve the tarball of the latest version from here: [http://archive.apache.org/dist/httpd/modpython/ PythonModule]. In order to install mod-python, you must first also install have apxs installed as well as the python-devel library package installed. Run these commands: 
     44{{{ 
     45# yum install httpd-devel 
     46# yum install python-devel 
     47}}} 
     48 Once these libraries are installed, and you have downloaded the mod_python tarball, run these commands. 
     49{{{ 
     50# tar xzvf mod_python-3.3.1.tgz 
     51# cd mod_python-3.3.1 
     52# ./configure --with-apxs=/usr/sbin/apxs --with-python=/usr/bin/python2.6 
     53# make  
     54# make install 
     55}}} 
     56 '''BUG:''' The mod_python file that you downloaded may have a bug in it. Please go to this [https://bugzilla.redhat.com/show_bug.cgi?id=465246 BugReport] to apply the patch if running make throws an error. 
     57 
    2658=== Custominstaller Builder === 
    2759=== Central Advertise Server V2 ===