Ticket #438 (closed task: wontfix)

Opened 10 years ago

Last modified 10 years ago

pushsoftwareupdate integration test deployment

Reported by: ivan Owned by: jsamuel
Priority: critical Milestone:
Component: sysadmin Version:
Severity: Medium Keywords:
Cc: justinc Blocking:
Blocked By:

Description

This integration test never got deployed, even though Brent completed it a while back. This test is intended to test the seattle software updater -- a critical component in Seattle.

We need to deploy this integration test on blackbox.cs and most likely we will need to coordinate with Brent to understand how to run this test properly.

This test will also have to be integrated with send_gmail to send an email in case of test failure.

Change History

Changed 10 years ago by justinc

  • priority changed from major to critical

Changed 10 years ago by monzum

  • cc justinc added
  • owner changed from monzum to jsamuel
  • status changed from new to assigned

The pushsoftwareupdate test doesn't seem to be ready for deployment. It seems there are quite a few TODOs left to do. For example the function check_success() doesn't check to see if the software update was successful and just passes without checking anything. As well as many of the values for variables seem to be hardcoded, such as installer_folder, update_base_url and svn_trunk_location. Perhaps pushsoftwareupdate should take in parameters for these variables.

pushsoftwareupdate.mix currently resides in trunk/integrationtests/pushsoftwareupdate/ and needs to be fixed before it is deployed. (Atleast the check_success() function needs to be working.)

Changed 10 years ago by justinc

I think this is a wontfix since it seems to be superseded by the new testing framework. Comments?

Changed 10 years ago by jsamuel

I don't know if it's superseded by the new testing framework. I think the issue is whether we feel we want something we'd call integration tests (even though the current software updater tests are largely integration tests already) and, if we do feel we need something more than the current tests, are these it? Given that these are unfinished according to earlier comments and we also have the opportunity to deploy to the beta testbed now (which we didn't when this ticket was created), I agree it's wontfix.

Changed 10 years ago by justinc

  • status changed from assigned to closed
  • resolution set to wontfix
Note: See TracTickets for help on using tickets.