Ticket #1108 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Error contacting local test nodes for seash

Reported by: leonwlaw Owned by: leonwlaw
Priority: major Milestone:
Component: seash Version: 0.1t
Severity: Medium Keywords: seash utf installer mac linux windows
Cc: leon.wlaw@… Blocking:
Blocked By:

Description (last modified by leonwlaw) (diff)

We get seash_exceptions.ParseError: Target does not exist errors. This appears to be related to the nodemanager that is started in order for the test to function. Additionally, the nodemanager does not seem to be shutdown correctly after the script ends.

Attachments

seash_mac_with_seattle.rtf Download (5.6 KB) - added by leonwlaw 7 years ago.
seash_mac_with_seattle.2.txt Download (5.2 KB) - added by leonwlaw 7 years ago.
seash_mac_with_seattle.txt Download (5.2 KB) - added by leonwlaw 7 years ago.
seash_mac_without_seattle.txt Download (2.6 KB) - added by leonwlaw 7 years ago.

Change History

Changed 7 years ago by leonwlaw

Changed 7 years ago by leonwlaw

Changed 7 years ago by leonwlaw

Changed 7 years ago by leonwlaw

  • keywords seash utf installer mac linux windows added
  • owner set to leonwlaw
  • status changed from new to accepted
  • component changed from - to seash

Changed 7 years ago by leonwlaw

  • description modified (diff)

Changed 7 years ago by leonwlaw

On mac, the issue of the empty lines vs. None errors seem to be mitigated by adding the "--test-mode" argument onto the line that starts the nodemanager. After this, the only errors that are left are the GeoIP and help string mismatches.

Changed 7 years ago by leonwlaw

  • description modified (diff)
  • summary changed from Failing unit tests in seash on some systems to Error contacting local test nodes for seash

Changed 7 years ago by leonwlaw

I separated this with the empty error messages since it is a separate issue.

Changed 7 years ago by leonwlaw

  • cc leon.wlaw@… added

The reason for the Target errors is due to the nodemanager still starting on port 1224, despite having the randomports option turned on. This is caused by nminit_test, where the port number is left as 1224. Changing the init script to nminit (which does have the random port) makes the node manager run on the correct port. Thanks to Monzur for helping me with this one.

However, seash will still not pickup these vessels via browse. If I use the nmclient to connect to the nmmanager directly, I see these vessels without problems.

Changed 7 years ago by leonwlaw

  • status changed from accepted to closed
  • resolution set to fixed

The test nodemanager wasn't listening on the correct port. Redirecting the init script to the actual init script didn't work because the actual init script didn't have the test vessel entries. I've modified the test init script so that it is also preprocessed by the preparetest script, so it too contains the proper port numbers.

Issue fixed.

Note: See TracTickets for help on using tickets.