Ticket #1092 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Python installation on Android is very confusing...

Reported by: justinc Owned by: gpress
Priority: major Milestone:
Component: installer Version: 0.1t
Severity: Medium Keywords:
Cc: mkaplan, albert Blocking:
Blocked By:

Description (last modified by justinc) (diff)

Our Python installer downloads their installer installer. Then the user has to find this installer and run it. Then they need to open what they installed and then click install.

This is really, really confusing. We should fix it.

Change History

  Changed 7 years ago by justinc

  • description modified (diff)

  Changed 7 years ago by justinc

  • cc mkaplan added

  Changed 7 years ago by justinc

  • cc albert added

follow-up: ↓ 5   Changed 6 years ago by mkaplan

I think the nicest approach would be to automatically launch the Python installer from Seattle.

Here are the results of my research into doing that:
*  http://stackoverflow.com/questions/5952516/install-apk-from-url
*  http://stackoverflow.com/questions/4604239/install-application-programmatically-on-android
*  http://stackoverflow.com/questions/4967669/android-install-apk-programmatically
*  http://android.amberfog.com/?p=98
*  http://osdir.com/ml/Android-Beginners/2009-08/msg00136.html
*  http://stackoverflow.com/questions/4859786/error-installing-apk-programitacally
*  http://stackoverflow.com/questions/576513/android-download-binary-file-problems

My problem was that I would get a android.content.ActivityNotFoundException if I tried setting the MIME type to "application/vnd.android.package-archive"

It seems that it would require downloading the APK to the SD Card (specifically), and then launching the installer from there.

in reply to: ↑ 4   Changed 6 years ago by justinc

Replying to mkaplan:

I think the nicest approach would be to automatically launch the Python installer from Seattle.
[snip]
It seems that it would require downloading the APK to the SD Card (specifically), and then launching the installer from there.

Who has to d/l the APK to the SD card? If we can do it, then I think the problem is solved.

Then ideally we would figure out how to do the Python install without complicated user interaction.

  Changed 6 years ago by justinc

  • owner changed from justinc to gpress
  • status changed from new to assigned

  Changed 6 years ago by gpress

  • status changed from assigned to closed
  • resolution set to fixed

fixed in r6362.

Note: See TracTickets for help on using tickets.