Ticket #1090 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Need buttons that let you back out without closing on Android

Reported by: justinc Owned by: mkaplan
Priority: major Milestone:
Component: installer Version: 0.1t
Severity: Medium Keywords:
Cc: yanyan Blocking:
Blocked By:

Description

The installer and Seattle On Android screen should both have a button that let you back out. The installer should have this be 'cancel' and the main Seattle On Android screen should be 'back'.

Attachments

fix_back.diff Download (1.4 KB) - added by mkaplan 7 years ago.
Fix for ticket #0190

Change History

Changed 7 years ago by justinc

  • owner changed from justinc to mkaplan
  • status changed from new to assigned

Changed 7 years ago by mkaplan

  • status changed from assigned to accepted

Perhaps I am missing a detail.
What does "without closing on Android" mean?

Is this just requesting an extra Button on the UI that should be the equivalent of pressing the hardware back button?

Changed 7 years ago by yanyan

Sorry for the confusion. The problem is hard back button does not work. To exit I had to hit home button instead.

Changed 7 years ago by mkaplan

Fix for ticket #0190

Changed 7 years ago by mkaplan

When the back button as pressed, it would do an action depending on the current view.
I added an else to that, that if it didn't match one of the previous views, it would just do the android's default action, which on the main screen is to exit.

Take a look at the attached diff. If it appropriately fixes this problem, I think it is ready to commit and close.

Changed 7 years ago by mkaplan

  • status changed from accepted to closed
  • resolution set to fixed

Fixed in r5951

Note: See TracTickets for help on using tickets.