Ticket #1082 (assigned defect)

Opened 7 years ago

Last modified 7 years ago

Nodemanager should not accept connections before it completes initialization

Reported by: albert Owned by: varungarg
Priority: major Milestone:
Component: node manager Version: 0.1t
Severity: Medium Keywords:
Cc: justinc, vijay, albert.rafetseder@… Blocking:
Blocked By:

Description

The node manager seems to accept connections on port 1224 before it's done initializing. I tried to upload file in seash, yielding

Failure 'Unknown status 'AddFileToVessel|v1|helloworld.repy|if callfunc=="initialize":
  print "Hello, world!"

!65537 99090486438149383522627442991443649968649386172700154237046194991416945801793620857061143453714288850730015650127462433306550581782429399244290904722186545647080221598464702247339846318771122264340186287896485439427255340567706022684889299315470846450438495472788603692209658107622493687166188134478440259361!3552976849.24!3552980449.24!None!65537 130045883643379962982035098177190115130969438560944298195244510383944370193490515011063624077409803615995077214360879340874549358859502399657565263197667848352827646956264830919636732493260668650677883219115687380711007207832721353820167682623067302267820510305920709882702967209949421443876465613713049926441! 39056225721706514930576318519956814399289319229291971402943268339346579339630005541301879159928243658705857112506808321615200475791968894948776271386214902896346794948219597483960407915651905353927726100630347220748540337994960055785733101595531370027099120856857506954713084063914438996068131412707324771148'' uploading to 90.152.224.128:1224:v1

Change History

Changed 7 years ago by justinc

  • cc vijay added
  • owner changed from justinc to varungarg
  • status changed from new to assigned

Changed 7 years ago by albert

  • cc albert.rafetseder@… added

I believe this happened as follows: The vessel (running on an Android smartphone) was still in my vessels list in seash, but the device had crashed, so I rebooted it. Following the reboot, Seattle cam up again. When I tried to upload a file, I was greeted with the error message above.

Curiously, seash claims that the (not-so-fully operational) node manager sends back a message that looks very much like the command initially sent by seash.

I was able to trigger the bug a few times, but it might just be a rare race condition on a slow device.

Note: See TracTickets for help on using tickets.